Задать вопрос
8 марта, 15:44

Дано предложение. Определить долю в процентах букв а в нем (pascal abc)

+5
Ответы (1)
  1. 8 марта, 17:44
    0
    Ну? как то так

    1) на pascal ABC

    var i:integer;

    n:real;

    a:string;

    begin

    readln (a) ;

    for i:=1 to length (a) do

    if a[i]='a' then n+=1;

    n: = (n/length (a) * 100) ;

    writeln (n:2:1) ;

    end.

    2) на pascal ABC

    var i, n:integer;

    a:string;

    begin

    readln (a) ;

    for i:=1 to length (a) do

    if (a[i]='p') and (a[i+1]='o') then n+=1;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано предложение. Определить долю в процентах букв а в нем (pascal abc) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
1. Дано предложение. Определить долю (в %) букв "а" в нём (предложения вводить самому) 2. Дано предложение.
Ответы (1)