Задать вопрос
3 марта, 09:49

Цикл с предусловием

Составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию деления.

+2
Ответы (1)
  1. 3 марта, 09:55
    0
    Var

    x, y, q, r: integer;

    begin

    read (x, y) ;

    r : = x;

    q : = 0;

    while r > = y do

    begin

    r : = r - y;

    q : = q + 1

    end;

    write (q,' ', r)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Цикл с предусловием Составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Какой тип данных может иметь параметр цикла? 2. В каких случаях при написании программ лучше использовать оператор цикла с предусловием? 3. В каких случаях цикл с предусловием может быть бесконечным? 4.
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)