Задать вопрос
26 октября, 04:42

Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2 + ... + X^n и проверьте ее работу при различных значениях X и натурального N

+1
Ответы (1)
  1. 26 октября, 07:03
    0
    Var

    s, cur: longint;

    x, n, i: integer;

    begin

    write ('x=') ; read (x) ;

    write ('n=') ; read (n) ;

    cur : = 1; s : = 0;

    for i : = 1 to n do begin

    cur : = cur * x;

    s : = s + cur;

    end;

    writeln ('sum=', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с Pascal Turbo. Нужно написать программуНаберите программу вычисления суммы S=X+X^2 + ... + X^n и проверьте ее работу при ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Написать программу вычисления суммы натуральных чисел от 1 до n Turbo Pascal
Ответы (1)