Задать вопрос
3 мая, 01:03

Дано натуральное число. найти номер цифры 3 в нем, считая от конца

+5
Ответы (1)
  1. 3 мая, 02:28
    0
    Var a, bug, m:integer;

    s:string;

    begin;

    readln (a) ;

    str (a, s) ; / / переводим число в строку

    writeln ('Result:') ;

    while pos ('3', s) 0 do / / пока 3 есть в строке выполнять

    begin;

    m:=length (s) - pos ('3', s) + 1; / / длина строки-позиция тройки+1

    delete (s, pos ('3', s),1) ; / / удаляем 3 из строки чтобы можно было проверить след.

    writeln (m) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. найти номер цифры 3 в нем, считая от конца ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Программирование цикл вайл язык С Вопрос №737412 (тип: C) Дано натуральное число N (N
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)