Задать вопрос
2 февраля, 00:13

Дан массив C целочисленный состоящий из 20 элементов каждый элемент которого вычесляется по формуле Ci=i*-5; Вывести данный массив и вывести новый массив элемент которого формируется таким образом: 1 элемент равен последнему элементу, 2 элемент равен перед последнему элементу

+4
Ответы (1)
  1. 2 февраля, 01:12
    0
    Программа, которая использует два массива

    var

    c, a: array[1 ... 20] of integer;

    i: integer;

    begin

    write ('Первый массив ') ;

    for i : = 1 to 20 do begin

    c[i] : = i * (-5) ;

    write (c[i], ' ') ;

    end;

    writeln;

    write ('Преобразованный массив ') ;

    for i : = 1 to 20 do begin

    a[i] : = c[20 - i + 1];

    write (a[i], ' ') ;

    end;

    end.

    ИЛИ Программа не использующая два массива, а просто переворачивающая первый

    var

    c: array[1 ... 20] of integer;

    i: integer;

    begin write ('Первый массив ') ;

    for i : = 1 to 20 do begin

    c[i] : = i * (-5) ;

    write (c[i], ' ') ;

    end;

    writeln;

    write ('Преобразованный массив ') ;

    for i : = 20 downto 1 do write (c[i], ' ') ;

    end.

    Обе программы работают!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив C целочисленный состоящий из 20 элементов каждый элемент которого вычесляется по формуле Ci=i*-5; Вывести данный массив и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)