Задать вопрос
20 мая, 06:14

Дан массив (а) из n элементов, нужно удалить 1 ый встретившиеся нулевой элемент из массива (помогите написать программу)

+5
Ответы (1)
  1. 20 мая, 07:50
    0
    Const

    n=13;

    var

    a:array[1 ... n] of integer;

    i, k, t:integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i:=1 to n do

    begin

    a[i]:=Random (21) - 10;

    Write (a[i],' ')

    end;

    Writeln;

    { начало собственно программы }

    i:=1; k:=0;

    while (i<=n) and (k=0) do

    begin

    if a[i]=0 then k:=i;

    i:=i+1

    end;

    if k>0 then

    begin

    for i:=k to n-1 do a[i]:=a[i+1];

    Writeln ('Массив-результат') ;

    for i:=1 to n-1 do Write (a[i],' ') ;

    Writeln

    end

    else

    Writeln ('В массиве нет нулевых элементов')

    end.

    Контрольное решение

    Исходный массив

    6 - 6 10 - 9 6 9 0 10 6 0 - 10 - 3 6

    Массив-результат

    6 - 6 10 - 9 6 9 10 6 0 - 10 - 3 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив (а) из n элементов, нужно удалить 1 ый встретившиеся нулевой элемент из массива (помогите написать программу) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)