Задать вопрос
11 июля, 14:47

Написать программу while ... do

Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат.

+1
Ответы (1)
  1. 11 июля, 15:53
    0
    Одно из возможных решений. Также можно использовать массив, если это необходимо за условием.

    const

    n = 10;

    var

    i, number: integer;

    begin

    i : = 1;

    while (i < = n) do

    begin

    write ('Введите ', i, '-ое число: ') ;

    readln (number) ;

    if sqr (number) < 100 then

    writeln ('Число: ', number, '. Квадрат числа: ', sqr (number), '.') ;

    Inc (i) ;

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу while ... do Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Переведите на язык программирования: а) ввести А и С увеличить А в 10 раз уменьшить С в 20 раз напечатать модуль разности А и С б) ввести А и С если А>С, то увеличить А в 5 раз иначе уменьшить С в 2 раза напечатать значения А и С конец в) ввести
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
13. Ввести a и b (
Ответы (1)
1) В поезде 17 вагонов, 10-17-купейные, остальные-плацкарт. Ввести № вагона. напечатать вид. 2) Ввести 2 числа. Напечатать их частное или сообщить, что на 0 делить нельзя
Ответы (1)
Составить программу в Pascal, используя цикл с счетчиком for 1. Напечатать квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b>10) 2. Напечатать все целые числа от a до b (значения a и b вводятся с клавиатуры)
Ответы (1)