Задать вопрос
10 июля, 00:28

В двумерном массиве, состоящем из целочисленных элементов, поменять местами в каждой строке наибольший и наименьший элементы.

+3
Ответы (1)
  1. 10 июля, 01:06
    0
    Var a:array[1 ... 100,1 ... 100] of integer; i, j, n, m, max, min:integer; begin write ('Введите количество строк: ') ; read (n) ; writeln; write ('Введите количество элементов в строке: ') ; read (m) ; writeln; writeln ('Введите массив: ') ; for i:=1 to n do begin for j:=1 to m do begin write (' a[', i,',', j,']=') ; read (a[i, j]) ; end; writeln; end; writeln; writeln ('Исходный массив: ') ; for i:=1 to n do begin for j:=1 to m do write (a[i, j],' ') ; writeln; end; writeln; writeln ('Конечный массив: ') ; for i:=1 to n do begin min:=a[i, 1]; max:=a[i, 1]; for j:=2 to m do begin if (min>a[i, j]) then min:=a[i, j]; if (max
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве, состоящем из целочисленных элементов, поменять местами в каждой строке наибольший и наименьший элементы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1. Дан массив из 20 элементов, принимающих значения от 0 до 50. Найти количество элементов, больших 25 и сумму элементов, меньших 25. 2. Найти в массиве наибольший элемент и поменять его местами с первым элементом.
Ответы (1)