Задать вопрос
30 марта, 14:13

Написать программу которая меняет 2 и 3 цифру в четырехзначном числе

+1
Ответы (1)
  1. 30 марта, 15:47
    0
    Var a, a1, a2, a3, a4, b:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a1:=a div 1000;

    a2:=a div 100 mod 10;

    a3:=a mod 100 div 10;

    a4:=a mod 10;

    b:=a1*1000+a3*100+a2*10+a4;

    writeln ('b = ', b) ;

    end.

    Пример:

    a = 4682

    b = 4862
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая меняет 2 и 3 цифру в четырехзначном числе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике