Задать вопрос
7 декабря, 01:12

Составьте программу, которая в массиве из 15 чисел складывает все элементы, больше 10

+1
Ответы (1)
  1. 7 декабря, 02:27
    0
    Const

    handsfree = true;

    n = 15;

    var

    a: array[1 ... n] of real;

    i: integer;

    sum: real;

    begin

    {ввод массива}

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) - 50;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {подсчет суммы и произведения}

    sum : = 0;

    for i : = 1 to n do

    begin

    if a[i] > 10 then

    sum : = sum + a[i];

    end;

    writeln ('sum = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая в массиве из 15 чисел складывает все элементы, больше 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)