Задать вопрос
1 апреля, 15:46

Вычислить сумму ряда до n количества значений S=1 + 1/2+1/4+1 / (8) ...

напишите программу в паскале

+4
Ответы (1)
  1. 1 апреля, 17:24
    0
    Не очень корректная постановка задачи, но понять можно.

    var n, i:integer; s, a:real;

    begin

    write ('n=') ; readln (n) ;

    s:=1; a:=1;

    for i:=2 to n do

    begin

    a:=a*2; s:=s+1/a;

    end;

    writeln ('s=', s:6:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму ряда до n количества значений S=1 + 1/2+1/4+1 / (8) ... напишите программу в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Тема одномерные массивы Написать программу в паскале: 1. Массив на 15 значений заполнен случайными числами посчитать количество нечетных значений 2.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. написать программу, производящее "неформатный" вывод разных значений 2. написать программу, производящее "форматный" вывод разных значений 3. написать программу использующие процедуру writeln c параметрами и без параметров
Ответы (1)
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ..
Ответы (1)