Задать вопрос
30 сентября, 10:38

Дано целое положительное значение (m). Требуется вычислить сумму:

1+1/1!+1/2!+1/3! ... + 1/m!

+3
Ответы (2)
  1. 30 сентября, 11:54
    -1
    Var

    i, m: integer;

    f:longint;

    s: real;

    begin

    readln (m) ;

    f : = 1;

    for i : = 1 to m do

    begin

    f : = f * i;

    s : = s + 1 / f;

    end;

    writeln (s) ;

    end.
  2. 30 сентября, 13:20
    -1
    Var

    factm:longint;

    m, i:byte;

    sum, y:real;

    begin

    sum:=0;

    factm:=1;

    write ('Введите значение m=') ; read (m) ;

    for i:=2 to m do

    factm:=factm*i;

    y: = (1/factm) ;

    sum:=sum+y;

    writeln ('Сумма=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое положительное значение (m). Требуется вычислить сумму: 1+1/1!+1/2!+1/3! ... + 1/m! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Дано целое положительное число. Проверить истинность высказывания: "данное число является нечетным трехзначным". Входные данные: ввести одно целое положительное число a ((1
Ответы (1)
Решите задачу на языке Pascal, применяя цикл с предусловием Дано целое положительное число N. Найти наименьшее целое положительное число K, квадрат которого превосходит N. Функцию извлечения квадратного корня не использовать.
Ответы (2)