Задать вопрос
4 сентября, 20:44

У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?

+5
Ответы (1)
  1. 4 сентября, 23:41
    0
    Задачу можно решать различными способами. Можно рассуждениями-вычислениями, а можно просто написать программу, в которой вычисляется нужное значение:

    var i, a, s, k:integer;

    begin

    k:=0;

    for i:=1 to 1024 do

    begin

    a:=i; s:=0;

    while a0 do

    begin s:=s+a mod 10; a:=a div 10; end;

    if s mod 4 = 0 then k:=k+1;

    end;

    writeln ('k = ', k) ;

    end.

    Результат:

    k = 253
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Написать на языке Packal
Ответы (1)
23 в 4 степени+21 в 8 степени = ответ в 10 степени 12 в 10 степени * 1010 в 2 степени = ответ в 3 степени (10101 в 2 степени + 212 в 3 степени) * 2 в 10 степени = ответ в 5 степени
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)