Задать вопрос
16 июня, 21:31

Дано предложение. Определить, сколько слов в данном предложении.

Именно слов, а не символов. В pascal abc.

+1
Ответы (1)
  1. 16 июня, 22:24
    0
    Если слова в предложении разделяются одним пробелом, то:

    var s:string; p, k:integer;

    begin

    writeln ('Введите предложение:') ;

    readln (s) ;

    s:=s+' ';

    k:=0;

    p:=pos (' ', s) ;

    while p0 do

    begin

    k:=k+1;

    delete (s, 1, p) ;

    p:=pos (' ', s) ;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    Введите предложение:

    Определить, сколько слов в данном предложении.

    k = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано предложение. Определить, сколько слов в данном предложении. Именно слов, а не символов. В pascal abc. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)