Задать вопрос
3 мая, 04:27

Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

+1
Ответы (1)
  1. 3 мая, 05:13
    0
    Program Main; Var a:array[1 ... 1000]of integer; i, n, k:integer; begin write ('Введите количество элементов в массиве: ') ; readln (n) ; writeln ('Введите массив: ') ; for i:=1 to n do read (a[i]) ; writeln; k:=0; for i:=1 to n-1 do if (a[i]=a[i+1]) then k:=k+1; if (k>0) then writeln ('Есть ', k,' пар соседних элементов с одинаковым значением') else writeln ('Нет пар соседних элементов с одинаковым значением') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел (до 10000) Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)