Задать вопрос
4 февраля, 04:08

Дан массив, состоящий из целых чисел (до 10000) Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

+3
Ответы (1)
  1. 4 февраля, 04:41
    0
    Const

    n = 20;

    var

    a: array[1 ... n] of integer;

    i: integer;

    flag: boolean;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (19999) - 9999;

    Write (a[i]:6) ;

    end;

    Writeln;

    i : = 1;

    flag : = False;

    repeat

    flag : = (sign (a[i]) = sign (a[i + 1])) ;

    i : = i + 1

    until flag or (i > n) ;

    if flag then Writeln ('Есть пара соседних элементов с одним знаком')

    else Writeln ('Нет пар соседних элементов с одним знаком')

    end.

    Тестовое решение:

    Элементы массива

    2440 - 2414 - 3192 - 6912 - 8537 7364 2869 - 2505 8875 2662 401 7398 2213 8804 2039 1485 4213 8359 - 2410 - 5844

    Есть пара соседних элементов с одним знаком
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив, состоящий из целых чисел (до 10000) Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)