Задать вопрос
5 марта, 13:29

Составьте программу вывода на экран n первых чисел Фибонаги (это числовая последовательность 1,1,2,3,5,8,23, ...), которые вычисляются по правилу: а1=1, а2=1, а3=а2+а1, ..., аn=аn-1+an-2 (после - а - это индексы!) pascal ABC

+5
Ответы (1)
  1. 5 марта, 16:08
    0
    Var i, n:integer; a, b:int64; begin read (n) ; a:=1; b:=1; if (n=1) then write (a) else if (n>=2) then write (a,', ', b) ; if (n>2) then for i:=1 to n-2 do begin b:=b+a; a:=b-a; write (', ', b) ; end; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вывода на экран n первых чисел Фибонаги (это числовая последовательность 1,1,2,3,5,8,23, ...), которые вычисляются по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
1) Составить программу вывода на экран первых 10 натуральных чисел 2) Составить программу вычисления суммы N первых чисел В Pascal
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
1. Написать программу. Условие задачи: Написать программу вывода на экран лесенкой трех последовательно идущих трехзначных чисел. Первое число вводит пользователь, остальные вычисляются в программе. Пример работы программы: 213 214 215
Ответы (2)