Задать вопрос
8 марта, 14:19

Дано трехзначное число. напишиье программу которая суммирует разряды числа

+1
Ответы (1)
  1. 8 марта, 15:19
    0
    Var n, s:integer;

    begin

    write ('n=') ; readln (n) ;

    s: = (n div 100) + (n div 10 mod 10) + (n mod 10) ;

    writeln ('s=', s) ;

    end.

    Пример:

    n=123

    s=6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано трехзначное число. напишиье программу которая суммирует разряды числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Написать программу которая про суммирует все 2 ух значные числа содержащие 1
Ответы (1)
Напишите программу, которая суммирует все четные числа от 15 до 25, а для всех нечетных находит сумму квадратов этиз числех
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)