Задать вопрос
26 мая, 22:09

Дано четырёхзначное число N. Определить делится ли это число на все свои цифры?

+2
Ответы (1)
  1. 26 мая, 22:24
    0
    Var a, a1, b, c:longint;

    begin

    write ('введите четырёхзначное число=> ') ;

    readln (a) ;

    a1:=a;

    while (a0) do begin

    b:=a mod 10;

    if (a1 mod b=0) then c:=c+1;

    a:=a div 10;

    end;

    if (c=4) then writeln ('делится')

    else writeln ('не делится') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырёхзначное число N. Определить делится ли это число на все свои цифры? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано четырехзначное число n. Выписать число в обратном порядке. n - четырехзначное число (1762) - исходные данные a, b, c, d - цифры этого числа (вспомогательные переменные). m - обратное число (результат) Решить через div и mod
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
Дано натуральное четырехзначное число. Определить все цифры в цифровой записи данного числа, на которые оно делится без остатка. Использовать только условный оператор "If", на языке Паскаль.
Ответы (1)