Задать вопрос
21 сентября, 11:11

Найти произведение чисел введеных с клавиатуры, пока не будет введен 0

+2
Ответы (1)
  1. 21 сентября, 12:02
    0
    Var a, b:integer;

    begin;

    b:=1;

    a:=1;

    while a0 do

    begin;

    readln (a) ;

    if a=0 then break;

    b:=b*a;

    end;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение чисел введеных с клавиатуры, пока не будет введен 0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
помогите решить задачю по информатике С клавиатуры последовательно вводят целые числа и высчитывается их сумма если с клавиатуры вводят 0, то больше числа не вводят. Найти сумму всех введеных чисел.
Ответы (1)
Язык Паскаль! 1) Вводить с клавиатуры числа, пока не будут введен 0. Найти количество введенных чисел. 2) Числа задаются случайно в диапазоне от [-10,10] и выводятся на экран. Находится сумма числе, пока число не станет равным 0.
Ответы (1)
Для четырёх произвольных чисел, введёных с клавиатуры, выведите на экран соответствующие результаты. Если произведение второго и четвёртого числа чётно, то выведите эти два числа и их произведение. Паскаль
Ответы (1)