Задать вопрос
20 мая, 23:22

Определить есть ли пара соседних элементов с суммой равной заданному числу. Составить на Паскале программу (массивы)

+3
Ответы (1)
  1. 20 мая, 23:44
    0
    Const

    n=10;

    var a:array[1 ... n] of integer;

    i, k, s:integer;

    begin

    k:=0;

    writeln ('Введите число') ;

    read (s) ;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do read (a[i]) ;

    for i:=2 to n do if a[i]+a[i-1]=s then k:=k+1;

    if k>0 then writeln ('Есть') else writeln ('Нету') ;

    end. 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить есть ли пара соседних элементов с суммой равной заданному числу. Составить на Паскале программу (массивы) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ? Если есть, то вывести индексы первой такой пары чисел.
Ответы (1)
Определить содержит ли последовательность хотя бы два соседних числа с одинаковыми знаками. И найти произведение их соседей ... -1,3,6,9,-10,7,-2,-8 -1 и 3 не пара 3 и 6 пара их про.
Ответы (1)
Есть ли в данном массиве элементы равные заданному числу? Если есть, то вывести номер одного из них. Работа в паскале, массивы.
Ответы (1)
Задача! 1. Дан массив целых чисел, состоящий из 15 элементов. Найти: 1) сумму положительных элементов, значения которых меньше 102) вывести индексы тех элементов, значения которых кратны 3 и 5. 2.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)