Задать вопрос
14 августа, 22:08

Определить содержит ли последовательность хотя бы два соседних числа с одинаковыми знаками. И найти произведение их соседей ...

-1,3,6,9,-10,7,-2,-8

-1 и 3 не пара

3 и 6 пара их про. = 18

6 и 9 пара = 54

9 и - 10 не пара

-10 и 7 не пара

7 и - 2 не пара

-2 и - 8 пара = 16

Только не через массивы ...

+2
Ответы (1)
  1. 15 августа, 01:21
    0
    Не совсем красиво но без массивов

    var cur_num, prev_num: integer;

    Begin

    Writeln ('Введите последовательность закончив ее нулем') ;

    read (prev_num) ;

    repeat

    read (cur_num) ;

    if cur_num * prev_num > 0 then

    writeln ('Пара = ', cur_num * prev_num) ;

    prev_num : = cur_num;

    until cur_num = 0;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить содержит ли последовательность хотя бы два соседних числа с одинаковыми знаками. И найти произведение их соседей ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
2. Могут ли существовать а) два ящика с одинаковыми именами на одном почтовом сервере, б) два ящика с одинаковыми паролями на одном почтовом сервере, в) два ящика с одинаковыми именами на разных почтовых серверах, г) два ящика с одинаковыми именами
Ответы (1)
Могут ли существовать а) два ящика с одинаковыми именами на одном почтовом сервере, б) два ящика с одинаковыми паролями на одном почтовом сервере, в) два ящика с одинаковыми именами на разных почтовых серверах, г) два ящика с одинаковыми именами и
Ответы (2)
Паскаль вводится последовательность из n целых чисел. определить, содержит ли последовательность хотя бы два равных соседних числа (a_i=a_ (i+1)) (без массива)
Ответы (1)
Задание звучит: Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками. Что нужно изменить в программе, чтобы выполнялось условие задачи.
Ответы (1)