Задать вопрос
28 августа, 18:06

Напишите программу алгоритмическим языком для нахождения НОД по Евклиду (делить большое число на меньшее, а потом ему присваивать значение остатка)

+2
Ответы (1)
  1. 28 августа, 22:04
    0
    Var a, b:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    while (a0) and (b0) do

    if a>b then a:=a mod b else b:=b mod a;

    writeln ('НОД=', a+b) ;

    end.

    Пример:

    a=125

    b=50

    НОД=25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу алгоритмическим языком для нахождения НОД по Евклиду (делить большое число на меньшее, а потом ему присваивать значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы