Задать вопрос
29 марта, 16:30

Чтобы найти наибольший общий делитель постройте программу используя эту формулу: нод (А, B, C) = нод (нод (А, B,), C). (через программу паскаль) program=Evklid

+1
Ответы (1)
  1. 29 марта, 18:31
    0
    Var a, b, c, x : integer;

    function NOD (a, b:integer) : integer;

    begin

    while ab do

    if a>b then

    a:=a-b

    else b:=b-a;

    Result:=a;

    end;

    begin

    write ('Введите a, b, c: ') ;

    readln (a, b, c) ;

    x:=NOD (NOD (a, b), c) ;

    writeln ('НОД=', x)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Чтобы найти наибольший общий делитель постройте программу используя эту формулу: нод (А, B, C) = нод (нод (А, B,), C). (через программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль
Ответы (1)
Дана программа на языке Паскаль: program а4; var х, kl, k2: integer; begin kl : = О; k2 : = О; repeat writeln ('Введите целое число') ; readln (х) ; if х
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)