Задать вопрос
14 апреля, 15:51

Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. Сколько амеб будет через N секунд? Проверить решение для 10, 25, 72 секунд.

+2
Ответы (1)
  1. 14 апреля, 16:29
    0
    Это просто! Вот решение:

    Var n, a, time:integer;

    Begin

    Readln (n) ;

    a:=1; time:=0;

    while time
    if frac (time/5) = 0 then a:=a*2;

    time:=time+1; / / èëè âìåñòî ýòîãî " Inc (time) ; "

    End;

    Writeln (a) ;

    End.

    И результаты проверки:

    10 секунд: 4 амёбы

    25 секунд: 32 амёбы

    72 секунды: 32768 амёбы
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике