Задать вопрос
8 сентября, 15:53

В-2

1) Опишите последовательность 30 действительных чисел с помощью массива.

2) Дан фрагмент программы:

For i:=1 to 10 do a[i]:=20-i * (i-1) ;

Определите элемент массива.

3) Дан массив (см задание 2). Определите результат работы фрагмента программы:

K:=0;

For i:=1 to 10 do

If a[i]>i then k:=k+1;

Write (k) ;

+2
Ответы (1)
  1. 8 сентября, 17:01
    0
    1) -

    2) 20 18 14 8 0 - 10 - 22 - 36 - 52 - 70

    3) 4

    код полностью

    var

    a: array[1 ... 10] of integer;

    i, k: integer;

    begin

    for i : = 1 to 10 do

    begin

    a[i] : = 20 - i * (i - 1) ;

    write (a[i], ' ') ;

    end;

    writeln;

    K : = 0;

    for i : = 1 to 10 do

    if a[i] > i then k : = k + 1;

    Write (k) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В-2 1) Опишите последовательность 30 действительных чисел с помощью массива. 2) Дан фрагмент программы: For i:=1 to 10 do a[i]:=20-i * ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В-3 1) Опишите последовательность 10 целых чисел с помощью массива 2) Дан фрагмент программы: For i:=1 to 10 do a[i]:=sqr (i) - i; Определите элементы массива 3) Дан массив (см задание 2).
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)