Задать вопрос
10 августа, 05:48

1. Имеется код программы на языке Паскаль:

var i, k: integer;

begin

k:=5;

for i : = 1 to 10 do

if i > 5 then

k:=k+1;

end;

Чему будет равно значение переменной k после выполнения кода?

Выберите один ответ:

3,14

15

1

6

10

+5
Ответы (1)
  1. 10 августа, 06:41
    0
    В коде используется неполный условный оператор, то есть нет else { ... }.

    Тогда условие i>5 будет выполняться только пять раз (i=6,7,8,9,10), в остальных случаях переменная k увеличиваться на единицу не будет. Значит при i=6 получим, что k=k+1=6 и так далее до i=10, k=10.

    Ответ 5) 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Имеется код программы на языке Паскаль: var i, k: integer; begin k:=5; for i : = 1 to 10 do if i > 5 then k:=k+1; end; Чему будет равно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Укажите области видимости в программе: Program P; Var x: integer; Procedure P1; Var y: integer; Begin P2; End; Procedure P2; Var z: integer; Begin {Тело процедуры} End; Procedure P3; Var m: integer; Begin P1; End; Begin {Тело основной программы}P3;
Ответы (1)
Какое число будет напечатано в результате выполнения программы: var i, k: integer; function f (x: integer) : integer; var m: integer; begin if x < 10 then f : = x else begin m : = f (x div 10) ; if m < x mod 10 then f : = x mod 10 else f : = m; end;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Переведите программу в Free Pascal var A: Array [1 ... 100] of integer; size: integer; Even: integer; notEven: integer; begin Write ('Set size A : ') ; Read (size) ; for i:integer : = 1 to size do begin Write ('Set A[', i, ']: ') ; Read (A[i]) ; end;
Ответы (2)
2. Имеется код программы на языке Паскаль: var i, k: integer; begin i:=1; k:=2; i:=k+i; case i of 2 : k:=11; 3 : k:=12; else k:=13; end; end; Чему будет равно значение переменной k после выполнения кода? Выберите один ответ: 13 12 11 2 15
Ответы (1)