Задать вопрос
28 марта, 22:35

Даны натуральное число n, действительные числа х1, ... хn. В этой последовательности заменить все элементы меньше 2, нулем. Кроме того, получить сумму элементов принадлежащих отрезку [3,7]

+5
Ответы (1)
  1. 29 марта, 01:05
    0
    Var n, i:integer;

    sum:real;

    a:array[1 ... 1024] of real;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if a[i]<2 then a[i]:=0;

    end;

    for i:=3 to 7 do

    sum:=sum+a[i];

    writeln ('summa=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральное число n, действительные числа х1, ... хn. В этой последовательности заменить все элементы меньше 2, нулем. Кроме того, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Дано целое число n и массив случайных чисел x[1 ... n]. все элементы, меньше 2, заменить нулями. Кроме того, получить сумму и количество элементов, п ринаднежащих отрезку [3; 7]
Ответы (1)
Массив заполнен целыми числами [-50:50] в массиве 10 чисел 1) найти сумму нечетных элементов 2) найти произведение элементов расположенных на четных местах, 3) все элементы кратные десяти заменить нулем найти число пар соседних элементов являющими
Ответы (1)
1) Дан массив целых чисел из 12 элементов. Напечатать все четные элементы. 2) Дан массив целых чисел из 10 элементов. Все элементы, кратные числу 10, заменить нулём. Нужна полная программа, Pascal ABC.
Ответы (1)
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)