Задать вопрос
31 марта, 03:39

Составьте программу в Паскаль. Седьмому классу на практике получено сдуть 1000 одуванчиков. Бригада мальчиков первый день сдуло А одуванчиков, а бригада девочек в два раза меньше. В каждый последующий день производительность мальчиков уменьшалась на 10 %, а девочек росла на 15 % по сравнению с предыдущим. Через сколько дней классы выполнит норму Вопросительный знак сколько сделают бригада мальчиков и девочек в отдельности?

+1
Ответы (1)
  1. 31 марта, 04:07
    0
    Хорошая задачка! Хочется её решать в целых числах, но в условии этого не требуется.

    var a, k:integer; m, d, sm, sd:real;

    begin

    write ('A=') ; readln (a) ;

    m:=a; d:=a/2;

    sm:=m; sd:=d;

    k:=1;

    while sm+sd<1000 do

    begin

    m:=m*0.9; sm:=sm+m;

    d:=d*1.15; sd:=sd+d;

    k:=k+1;

    end;

    writeln ('k=', k,' sm=', sm:6:2,' sd=', sd:6:2) ;

    end.

    Пример:

    A=70

    k=9 sm=428.81 sd=587.50
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в Паскаль. Седьмому классу на практике получено сдуть 1000 одуванчиков. Бригада мальчиков первый день сдуло А ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Мальвина решила научить Буратино писать предложения и ставить знаки препинания: точку, запятую, восклицательный и вопросительный знак. За первый месяц Мальвина сможет научить Буратино писать предложения.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?
Ответы (1)
Составить циклическую блок-схему к задаче: Начав тренировки, сортсмен в день пробегал 10 км, каждый последующий день он увеличивал норму на 50% от предыдущей. Через сколько дней он пробежит суммарный путь 60 км?
Ответы (1)
Составить программу на языке Паскаль. Спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Через сколько дней спортсмен будет пробегать более 20 км в день?
Ответы (1)