Задать вопрос
8 сентября, 13:21

Дано: массив A (N, M). В каждом столбце найти количество элементов, равных 1 или 2. Из полученных значений сформировать одномерный массив.

+5
Ответы (1)
  1. 8 сентября, 14:02
    0
    Var A:[1 ... 100,1 ... 100] of Integer;

    B:[1 ... 100] of Integer;

    i, j, N, M:integer;

    begin

    Readln (N, M) ;

    For i:=1 to N do

    For j:=1 to M do

    A[i, j]:=Random (0,3) ;

    For i:=1 to N do

    begin

    For j:=1 to M do

    Write (A[i, j];

    Writeln;

    end;

    For i:=1 to N do

    For j:=1 to M do

    If (A[i, j]=1) or (A[i, j]=2) then

    B[j]:=B[j]+1;

    For i:=1 to M do

    Write (B[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано: массив A (N, M). В каждом столбце найти количество элементов, равных 1 или 2. Из полученных значений сформировать одномерный массив. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Массив А (N, M). В каждом столбце найти среднее арифметическое нечетных элементов. Из полученных значений сформировать одномерный массив.
Ответы (1)
Дан одномерный массив. Из элементов массива равных 100, сформировать массив b., а из элементов меньших 33, сформировать массив с.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)