Задать вопрос
30 октября, 06:13

Введите с клавиатуры в массив пять целочисленных значений. Выведите их в одну строку через запятую. Получите для массива среднее арифметическое. Программу на паскале Борланд если можно (бп).

+1
Ответы (2)
  1. 30 октября, 06:59
    0
    Var a: array[1 ... 5] of integer;

    sr, i: integer;

    s: string;

    sar: real;

    begin

    sr:=0;

    s:='';

    for i:=1 to 5 do

    begin

    readln (a[i]) ;

    sr:=sr+a[i];

    s:=s+IntToStr (a[i]) + ', ';

    end;

    sar:=sr/5;

    s[Length (s) ]:='';

    writeln (s) ;

    writeln ('среднее равно: ', sar) ;

    end.
  2. 30 октября, 09:02
    0
    { Borland Pascal 7.01 }

    uses Crt;

    const

    n=5;

    var

    a:array[1 ... n] of integer;

    i:integer;

    avg:real;

    begin

    ClrScr;

    Write ('Введите 5 целых чисел: ') ;

    avg:=0;

    for i:=1 to n do begin Read (a[i]) ; avg:=avg+a[i] end;

    avg:=avg/n;

    for i:=1 to n-1 do Write (a[i],',') ; Writeln (a[n]) ;

    Writeln ('Среднее значение = ', avg) ;

    ReadKey

    end.

    Тестовое решение:

    Введите 5 целых чисел: 18 10 6 13 15

    18,10,6,13,15

    Среднее значение = 1.2400000000E+01
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры в массив пять целочисленных значений. Выведите их в одну строку через запятую. Получите для массива среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)