Задать вопрос
26 марта, 06:03

Написать программу для Pascal.

Вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

+5
Ответы (1)
  1. 26 марта, 10:01
    0
    Var a, b, k1, k2, s:integer;

    begin

    s:=0;

    k1:=0;

    writeln ('Введите начало и конец отрезка') ;

    read (a, b) ;

    k2:=b-a+1;

    repeat

    if b<0 then break;

    s:=s+b;

    b:=b-1;

    inc (k1) ;

    until (b=-1) or (b=a-1) ;

    writeln ('Сумма всех целых положительных чисел на отрезке = ', s) ;

    writeln ('Количество отрицательных целых чисел = ', k2-k1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для Pascal. Вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)