Задать вопрос
17 июля, 19:34

Дан одномерный целочисленный массив размерностью N. Сформировать новый массив из элементов исходного, кратных заданному числу а и больших по модулю их

индекса. Если такие элементы отсутствуют, то выдать об этом сообщение. паскаль

+3
Ответы (1)
  1. 17 июля, 20:06
    0
    Const n = 10;

    var

    b: array[1 ... n] of integer;

    c: array[1 ... n] of integer;

    i, a, k: integer;

    begin

    //считываем массив b

    for i:=1 to n do

    readln (b[i]) ;

    //вводим a

    readln (a) ;

    k:=0;

    for i:=1 to n do

    //если элемент кратен А и по модулю больше I то

    if (b[i] mod a = 0) and (abs (b[i]) > i) then

    begin

    //увеличиваем k на 1 и присваиваем c[k] a[i]

    inc (k) ;

    c[k] : = b[i];

    end;

    if k = 0 then

    writeln ('Таких элементов нет')

    else

    for i:=1 to k do

    writeln (c[k]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный целочисленный массив размерностью N. Сформировать новый массив из элементов исходного, кратных заданному числу а и больших ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)