Задать вопрос
14 апреля, 04:26

Ограничение времени: 1 секунда.

Однажды Петя играл с младшей сестрой в кубики и решил построить ей домик

в форме куба. Для домика высотой в 2 кубика понадобилось 8 кубиков, для домика

высотой 3 кубика понадобилось 27 кубиков, а на домик высотой в 4 кубика не хватило

кубиков, и сестренка очень расстроилась. Петя решил, что прежде чем начинать строить,

нужно проверить, хватит ли кубиков на дом необходимого размера. Помогите вычислить

Пете необходимое число кубиков для постройки домика высотой в n кубиков.

Входные данные Единственная строка содержит одно целое число n (1 ⩽ n ⩽ 109) -

высота домика. Гарантируется, что в 30% тестов n ⩽ 1000, а в 60% тестов n ⩽ 106.

Результат Нужно вывести одно число - количество кубиков для постройки домика.

Пример

Исходные данные Результат

2 8

+1
Ответы (1)
  1. 14 апреля, 07:04
    0
    Var

    a:longint;

    begin

    readln (a) ;

    writeln (a*a*a) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ограничение времени: 1 секунда. Однажды Петя играл с младшей сестрой в кубики и решил построить ей домик в форме куба. Для домика высотой в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая возводит натуральное число A в натуральную степень B. Входные данные Входная строка содержит два числа, A и B, разделённые пробелом. Гарантируется, что 1 ≤ A, B ≤ 1000.
Ответы (1)
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере (пробелы важны!) : Входные данные Вводится целое число (гарантируется, что число находится в диапазоне от - 1000 до + 1000).
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)