Задать вопрос
21 сентября, 17:41

Напишите программу, которая возводит натуральное число A в натуральную степень B.

Входные данные

Входная строка содержит два числа, A и B, разделённые пробелом. Гарантируется, что 1 ≤ A, B ≤ 1000.

Выходные данные

Программа должна вывести одно число: A в степени B.

Примеры

входные данные

2 6

выходные данные

64.

Паскаль ABC 1.8

+4
Ответы (1)
  1. 21 сентября, 21:24
    0
    Program n1;

    procedure st (n:longint; k: integer) ;

    var i, m : longint;

    begin

    m:=n;

    for i:=1 to k-1 do n:=n*m; writeln (n) ;

    end;

    var a, b: integer;

    begin

    readln (a, b) ;

    if (a>=1) and (b<=1000) then st (a, b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая возводит натуральное число A в натуральную степень B. Входные данные Входная строка содержит два числа, A и B, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу в Python 3.3 Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)