Задать вопрос
17 июля, 22:50

Паскаль. "циклы с условием"

факториалом натурального числа n называется произведение n!=1*2*3*4*5 * ... * n. подсчитать чему равняется 7!

+1
Ответы (1)
  1. 17 июля, 23:12
    0
    Var f, i:integer;

    begin

    i:=1;

    f:=1;

    while i<7 do

    begin

    i:=i+1;

    f:=f*i;

    end;

    writeln (i,'! = ', f) ;

    end.

    Результат:

    7! = 5040
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. "циклы с условием" факториалом натурального числа n называется произведение n!=1*2*3*4*5 * ... * n. подсчитать чему равняется 7! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задание: сделать функцию определения того, что данное число является факториалом: function reversef (f: integer; var n: integer) : boolean (возвращает true, если f - факториал, n - число, факториалом которого является f.
Ответы (1)
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N! = 1·2·3 ... (N - 1) · N.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)