Задать вопрос
18 января, 15:16

Дан массив B (n*m). Элементы массива ввести в программе. Найти сумму четных элементов массива. Паскаль

+2
Ответы (1)
  1. 18 января, 17:18
    0
    Program bi;

    type tab=array[1 ... 100,1 ... 100] of integer;

    var n, m, i, j, s:integer;

    t:tab;

    begin

    readln (n) ;

    readln (m) ;

    for i:=1 to n do

    for j:=1 to m do

    readln (t[i][j]) ;

    for i:=1 to n do

    for j:=1 to m do

    if (t[i][j] mod 2=0) then S:=S+t[i][j];

    writeln ('Mассив:') ;

    for i:=1 to n do begin

    writeln;

    for j:=1 to m do

    write (t[i][j],' ') ;

    end;

    writeln ('сумма чётныч чисел ', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив B (n*m). Элементы массива ввести в программе. Найти сумму четных элементов массива. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)