Задать вопрос
23 марта, 19:21

Составте програму из 10 элементов массива [-8; 8] подсчитывает количество нечётных чисел, все четные заменяет нулём

+4
Ответы (1)
  1. 23 марта, 22:31
    0
    Var i, k:integer; a:array[1 ... 10] of integer;

    begin

    for i:=1 to 10 do begin a[i]:=random (17) - 8; write (a[i]:4) ; end;

    for i:=1 to 10 do

    if a[i] mod 20 then inc (k) else a[i]:=0;

    writeln;

    for i:=1 to 10 do write (a[i]:4) ;

    writeln;

    writeln ('кол-во нечет=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте програму из 10 элементов массива [-8; 8] подсчитывает количество нечётных чисел, все четные заменяет нулём ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Паскаль! напишите програму, которая формирует массив из N элементов (максимальное количество ровно 20), значения элементов массива - случайные числа от-10 до 25.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)