Задать вопрос
16 июля, 03:50

Дан одномерный массив из 30 элементов, составить программу для подсчета произведения четных элементов этого массива.

+4
Ответы (1)
  1. 16 июля, 07:42
    0
    Program z1;

    var A:array[1 ... 30] of integer;

    i, k:integer;

    begin

    k:=1;

    for i:=1 to 30 do begin

    write ('a[', i,']=') ;

    read (a[i]) ;

    end;

    for i:=1 to 30 do

    if a[i] mod 2=0 then

    k:=a[i]*k;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив из 30 элементов, составить программу для подсчета произведения четных элементов этого массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)