Задать вопрос
18 сентября, 16:20

Найти сумму нечетных чисел кратных 8 от 1 до 100

+5
Ответы (1)
  1. 18 сентября, 17:53
    0
    Хоть и тупо, и сумма нечетных чисел кратных 8 равна 0, вот решение на паскале:

    var

    i, s: integer;

    begin

    s:=0;

    //проверяем каждое число от 1 до 100

    for i:=1 to 100 do

    //если остаток i на 2 не равен нулю

    //и остаток i на 8 равен нулю, то s увеличиваем на i

    if (i mod 2 0) and (i mod 8 = 0) then

    inc (s, i) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму нечетных чисел кратных 8 от 1 до 100 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)