Задать вопрос
19 июня, 08:26

Помогите написать программу в паскале, буду благодарна! С клавиатуры введите одномерный массив округлить (round) и вывести все числа, произведение всех элементов по модулю (abs)

+3
Ответы (1)
  1. 19 июня, 11:06
    0
    Const N = ...;

    var a:array[1 ... N] of integer;

    i: integer;

    c: real;

    begin

    for i:=1 to N do begin

    read (c) ;

    a[i]:=round (c) ;

    end;

    c:=1;

    for i:=1 to N do begin

    write (a[i],' ') ;

    c:=c*a[i];

    end;

    write ('произведение элементов по модулю равно', abs (c)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале, буду благодарна! С клавиатуры введите одномерный массив округлить (round) и вывести все числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)