Задать вопрос
8 мая, 01:11

Помогите решить задачку Pascal

Ввести целое положительное число и определить верно ли что сумма его цифр больше 15

+1
Ответы (1)
  1. 8 мая, 01:20
    0
    Var n, sum: integer;

    begin

    read (n) ;

    while (n>0) do begin

    sum:=sum + (n mod 10) ;

    n:=n div 10;

    end;

    if (sum>15) then write ('Верно') else write ('Неверно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачку Pascal Ввести целое положительное число и определить верно ли что сумма его цифр больше 15 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дано целое положительное число. Проверить истинность высказывания: "данное число является нечетным трехзначным". Входные данные: ввести одно целое положительное число a ((1
Ответы (1)