Задать вопрос
9 апреля, 01:57

Дан массив целых чисел из 8 элементов Указать те их них, у которых остаток от деления на M равен 1. (Pascal)

+2
Ответы (1)
  1. 9 апреля, 05:15
    0
    Program pr;

    uses crt;

    var

    mas: array[1 ... 8] of integer;

    M, i:integer;

    Begin

    writeln ('Введите M') ;

    readln (M) ;

    writeln ('Введите массив') ;

    for i:=1 to 8 do

    readln (mas[i]) ;

    writeln;

    {вывод необходимых элементов}

    for i:=1 to 8 do

    if mas[i] mod M = 1

    then writeln ('mas[', i, ']=', mas[i]) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из 8 элементов Указать те их них, у которых остаток от деления на M равен 1. (Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)