Задать вопрос
7 декабря, 16:49

Массив arr[6] заполнен единицами. Написать программу, которая используя датчик случайных целых чисел, получает на каждом шаге цикла случайное значение индекса массива х и выполняет операцию arr[x]=0. Найти среднее число, при котором все значения элементов массива будут заменены на нули.

+2
Ответы (1)
  1. 7 декабря, 18:25
    0
    Var arr:array [1 ... 6] of integer; i, k, x, s, d, j:integer; beginrandomize; d:=0; for j:=1 to 1000 dobeginfor i:=1 to 6 do arr[i]:=1; k:=1; s:=1; while k0 do begin x:=random (6) + 1; arr[x]:=0; if (arr[1]=0) and (arr[2]=0) and (arr[3]=0) and (arr[4]=0) and (arr[5]=0) and (arr[6]=0) then k:=0; s:=s+1; end; d:=d+s; end; Writeln ('В среднем цикл отработал ', d/1000,' раз') ; end.

    В среднем цикл отработал 15.946 разПри многократном запуске получается около 16 раз
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив arr[6] заполнен единицами. Написать программу, которая используя датчик случайных целых чисел, получает на каждом шаге цикла ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите найти ошибку в программе, при запуске на строке "vyvod (arr) ; " выдает ошибку: "Ожидалось выражение". Не пойму в чем проблема. uses crt; type arr=array [1 ...
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)