Задать вопрос
25 февраля, 05:06

Число X получают след образом: слева на право записывают без пробелов подряд числа от 1 до N (12345678910 ... N). По числу N определить, сколько цифр в числе X

+5
Ответы (2)
  1. 25 февраля, 06:30
    0
    Var n, i:longint;

    Begin

    readln (n) ;

    for i:1 to n do

    write (i) ;

    writeln (n) ;

    End.
  2. 25 февраля, 06:53
    0
    Var

    cnt, i, tmp, n, ans:longint;

    begin

    Writeln ('Введите n - > ') ;

    Readln (n) ;

    for i: = 1 to n do

    begin

    tmp: = i;

    cnt: = 0;

    while tmp > 0 do

    begin

    inc (cnt) ;

    tmp : = tmp div 10;

    end;

    ans: = ans + cnt;

    end;

    Writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Число X получают след образом: слева на право записывают без пробелов подряд числа от 1 до N (12345678910 ... N). По числу N определить, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
даны числа 400, 121, 93,80, 4. прочитай правила и запиши на каждом листке. если число нечётное то его записывают на листке с подписью дик если число нечётное и трехзначное то его записывают на листке с подписью ник если число четное или трехзначное
Ответы (1)
Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)