Задать вопрос
8 сентября, 18:43

С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal.

+3
Ответы (1)
  1. 8 сентября, 21:25
    0
    Var a, s, m: integer;

    begin

    while m < 5 do begin

    read (a) ;

    s : = s + a;

    if (a div 100 > 0) and (a div 100 < 10) then m : = 5;

    end;

    writeln (s-a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся целые числа до тех пор пока не введенно трехзначное число. Найдите сумму введенных чисел, кроме последнего. Paskal. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Пользователь вводит числа до тех пор, пока она в сумме не дадут число, кратное трем и оканчивающиеся на 3. После чего выводится сообщение о выигрыше в размере среднего арифметического введенных чисел. Решить с помощью динамического массива, в Paskal.
Ответы (1)
Подсчитать произведение целых чисел, введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа от - 10 до + 10 Через While решать!
Ответы (1)
Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until
Ответы (1)