Задать вопрос
6 июля, 21:16

Подсчитать произведение целых чисел, введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа от - 10 до + 10

Через While решать!

+1
Ответы (1)
  1. 7 июля, 00:06
    0
    var

    pr, x:integer;

    begin

    pr : = 1;

    write ('Введите число ') ; readln (x) ;

    while (x = - 10) do

    begin

    Pr : = pr * x;

    write ('Введите число ') ;

    readln (x) ;

    end;

    writeln ('Произведение чисел = ', pr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать произведение целых чисел, введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа от - 10 до + 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение целых чисел введенных с клавиатуры. Произведение подсчитывается до тех пор, пока вводятся числа в интервале от - 10 до + 10 через repeat ... until
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Для числа подсчитывается сумма его цифр. Если результат превышает 9, то для результата снова подсчитывается сумма цифр и так далее, пока результат не станет меньше 10. Выполните расчеты для введенного с клавиатуры не более чем 50-значного числа.
Нет ответа
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)