Задать вопрос
1 марта, 02:42

Написать программу в Паскале, массив который меняет 5 и 3 строку.

+3
Ответы (1)
  1. 1 марта, 03:57
    0
    Const n=6; m=4;

    var

    a:array[1 ... n, 1 ... m] of integer;

    i, j, c:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (50) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    for j:=1 to m do

    begin

    c:=a[3, j]; a[3, j]:=a[5, j]; a[5, j]:=c;

    end;

    writeln ('Полученный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do write (a[i, j]:4) ;

    writeln;

    end;

    end.

    Пример:

    Исходный массив:

    25 4 33 17

    19 23 42 9

    36 40 1 48

    21 44 13 18

    38 29 8 7

    24 13 5 13

    Полученный массив:

    25 4 33 17

    19 23 42 9

    38 29 8 7

    21 44 13 18

    36 40 1 48

    24 13 5 13
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале, массив который меняет 5 и 3 строку. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)
В виде программ: 1 Заполнить массив N числами (N
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
Напишите решение задачи через паскаль. 1. Массив из 10 целых чисел из промежутка [10,20] задается с помощью гениратора случайных чисел. Вывести полученный массив в строку. Затем увеличить каждый элемент на 5.
Ответы (1)