Задать вопрос
7 апреля, 12:12

Даны целое трехзначное число N и цедое число k. написать программу, подсчитывающую сумму цифр числа N, которые больше k

+4
Ответы (1)
  1. 7 апреля, 14:12
    0
    Var N, k, sum : Integer;

    Begin

    sum:=0;

    Readln (N, k) ;

    While N>0 do

    Begin

    If (N mod 10) >k then sum:=sum + (N mod k) ;

    N:=N div 10;

    end;

    end.

    или так

    Var N, k, sum : Integer;

    Begin

    sum:=0;

    Readln (N, k) ;

    While N>0 do

    Begin

    sum:=sum + (N mod 10) * Ord ((N mod 10) >k) ;

    N:=N div 10;

    end;

    end.

    или так

    Var N, k : Integer;

    Function sum (N, k : Integer) : Integer;

    Begin

    If (N>0) and ((N mod 10) >k) then sum: = (N mod 10) + sum (N div 10, k) else sum:=0;

    end;

    Begin

    Readln (N, k) ;

    Writeln (sum (N, k)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целое трехзначное число N и цедое число k. написать программу, подсчитывающую сумму цифр числа N, которые больше k ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дан трехзначное число n и целое число k. Напишите программу подсчитывающую сумму
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Даны целые числа а в с написать программу, подсчитывающую сумму тех чисел из данных, которые больше 0
Ответы (1)