Задать вопрос
21 сентября, 08:43

Напишите программу, размещающую в памяти два вектора и вычисляющую их скалярное произведение.

+4
Ответы (1)
  1. 21 сентября, 12:29
    0
    { Free Pascal - fpc 2.6.4 }

    var

    i, n:integer;

    A, B:array of integer;

    p:longint;

    begin

    Write ('Число элементов в векторах=') ; Read (n) ;

    Randomize;

    SetLength (A, n) ;

    Writeln ('Вектор A') ;

    for i:=0 to n-1 do begin A[i]:=Random (51) - 25; Write (A[i],' ') end;

    Writeln;

    SetLength (B, n) ;

    p:=0;

    Writeln ('Вектор B') ;

    for i:=0 to n-1 do begin

    B[i]:=Random (51) - 25;

    Write (B[i],' ') ;

    p:=p+A[i]*B[i]

    end;

    Writeln;

    Writeln ('Скалярное произведение равно ', p) ;

    end.

    Тестовое решение:

    Число элементов в векторах=15

    Вектор A

    -16 - 6 - 1 6 - 6 7 22 4 16 19 3 - 21 19 22 7

    Вектор B

    21 21 - 2 - 8 - 3 25 - 4 20 6 - 11 8 10 - 16 - 16 19

    Скалярное произведение равно - 1145
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, размещающую в памяти два вектора и вычисляющую их скалярное произведение. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)